Suivre

Quand tu as besoin d'une appli qui n'est dispo qu'en AppImage... et que du coup tu dois installer AppImage lui-même, et qu'au moment de l'installer il exige de dé-installer CES PAQUETS LÀ:

NON MAIS PARDON ??? 😡

Flatpak, Snap, AppImage: mais vous me cassez les couilles, en fait.

@sebsauvage Mais wat. C'est parce que ces logiciels existent aussi en AppImage et que du coup tu es obligé de les réinstaller sous cette forme ?

@lamecarlate

Non mais attend je me fais chier pour rien.

Un AppImage ça se lance tel quel, pas besoin du lanceur à la con.

@lamecarlate @sebsauvage C’est surtout que le soft dépends de libcurl3 qui fait conflit avec libcurl4 qui est nécessaire pour les 3 autres softs.

@sebsauvage
Mair quelles saloperies... Ça donne envie d'aimer les livraisons par docker

@Katyucha

Non mais en fait je viens de réaliser que je n'ai pas besoin du launcher appImage.

Un AppImage se lance directement.

Le lanceur, c'est juste pour installer automatiquement les raccourcis.

AppImage reste quand même bien meilleur que Snap et Flatpak.

@lpenou @Katyucha

Une manière de packager les applications pour les distribuer.

appimage.org/

C'est pas la pire des 3 (flatpak et snap sont bien pires)

@sebsauvage
C'était pas Red Hat qui voulait aussi faire une nouvelle méthode de packager en plus des 3 ?
Ils ont même réalisé une version spéciale où tout était en mode conteneur.

Ah moins que ce ne soit CentOS... 🤔
@lpenou @Katyucha

@Egide

Non c'est un lanceur pour les .AppImage

mais je viens de réaliser que je peux lancer les AppImage directement, je n'ai donc pas besoin de ce lanceur.

@sebsauvage
Ah oui. Effectivement j'utilise publii et le client Nextcloud en AppImage, lancement direct (debian testing)

@Egide
Question con, comment on les lance automatiquement au démarrage sous debian (c'est un launcher qu'il faut avoir ?)
@sebsauvage

@akira @sebsauvage
Très simplement, sous gnome avec l'éditeur de menu, la commande :
~/bin/Nextcloud-2.6.2-x86_64.AppImage
évidemment depuis le terminal même commande, penser à rendre AppImage exécutable.

@sebsauvage rhoo mais c'est scandaleux ! J'imagine qu'Appimage va les réinstaller à sa sauce, dans son environnement, ce qui est pénible parce qu'on y retrouve pas exactement la même arborescence de fichiers.

@talou

Non mais je viens de réaliser qu'un appImage peut se lancer directement.
Entre Flatpak et Snapd, c'est le moins pire des 3.

@sebsauvage ah mais oui, exact, je confond avec flatpak.
Bon par contre, chez moi les appimages ne se lancent plus (mint 18), un bug de setu de Fuse. Du coup décompression avec --appimage-extract puis lancement manuel dans le répertoire...
Ça remarchera à la prochaine install de mint

@sebsauvage …mais quel rapport ? virtualbox encore on peut se dire qu'il y a un conflit de version avec un device ou un module quelconque… mais curl ?

@cdlm
Aucun fichue idée. Peut-être libcurl jusement (VirtualBox s'en sert peut-être pour aller chercher les additions invité ?)

Enfin bref, je me suis fait chier pour rien: les appimages peuvent se lancer directement, sans ce lanceur spécifique.

@sebsauvage
J'ai commencé à pester aussi quand j'ai voulu tester Session jusqu'à ce que je me rende compte sur duck.com qu'il s'agit en fait d'un simple exécutable

Inscrivez-vous pour prendre part à la conversation
Framapiaf

Le réseau social de l'avenir : Pas d'annonces, pas de surveillance institutionnelle, conception éthique et décentralisation ! Possédez vos données avec Mastodon !