Suivre

Je veux relancer HyperLight Drifter sus Linux:

"mmmm... gneu gneu gneu j'ai besoin de libcurl3".

>sudo apt install libcurl3:i386
E: Impossible de trouver le paquet libcurl3:i386

La fatigue ces dev qui ont déjà totalement laissé tomber un jeu sorti il y a seulement 4 ans.

Donc ce jeu ne tournera sur plus aucun distribution récente.

@sebsauvage
Oula... Tu paniquerais pas un peu vite toi ?
La libcurl doit se trouver...

Respire un grand coup, et fait une recherche.

Dernière solution : un container dédié à ce jeu avec une distribution ancienne...

@djayroma

BON OK J'AI RÉUSSI.
Mais quelle affreuse grosse bidouille.

Je vais documenter ça sur mon wiki.

Man dieu que c'est laid.

@sebsauvage Sur un Ubuntu 20.04, j'ai fais un
>sudo apt install libcurl3-gnutls:i386
ça a fonctionné

@philippe_noel
J'ai ce paquet installé chez moi, mais HyperLight Drifter ne démarre pas.

Je vais faire un tuto pour expliquer comment télécharger et mettre à la main les libs nécessaires pour un jeu, même si elles ne sont plus dispo dans la distribution.

@sebsauvage
Arf. Je t'avoue que j'ai testé le jeu qu'une fois le paquet installé donc ça se trouve il y a un autre paquet déjà présent qui permettait de le faire tourner.

@sebsauvage /me cherche libssl.so.1.0
Et non le jeu concerné ne veut pas de la version 1.1 😭​

@Xalofar

J'ai réussi à le lancer.
Je suis en train de documenter sur mon wiki comment on résoud ce genre de problème.

@Xalofar @sebsauvage Il existe toujours la solution de récupérer la lib et de la ranger dans un endroit couvert par LD_LIBRARY_PATH.

Ça se fait bien ou alors de faire des liens symboliques des nouvelles versions vers le symbole que le jeu attends si ya pas eu de cassure dans le changement de version ça passe!

Inscrivez-vous pour prendre part à la conversation
Framapiaf

Le réseau social de l'avenir : Pas d'annonces, pas de surveillance institutionnelle, conception éthique et décentralisation ! Possédez vos données avec Mastodon !